[OSSRH-2957] Getting "Error deploying artifact: Authorization failed: Access denied" when attempting to deploy a ScalaTest snapshot Created: 02/11/12  Updated: 04/09/12

Status: Open
Project: Community Support - Open Source Project Repository Hosting
Component/s: None
Affects Version/s: None
Fix Version/s: None

Type: Task Priority: Major
Reporter: Bill Venners Assignee: Unassigned
Resolution: Unresolved Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Attachments: XML File pom.xml    
Last Updated By: Joel Orlina
Date of First Response:

 Description   

I think I followed all the instructions on this page:

https://docs.sonatype.org/display/Repository/Sonatype+OSS+Maven+Repository+Usage+Guide

I'm trying to deploy a ScalaTest 1.8-SNAPSHOT release, and am getting this problem:

[artifact:mvn] [INFO] Scanning for projects...
[artifact:mvn] [INFO] ------------------------------------------------------------------------
[artifact:mvn] [INFO] Building Maven Default Project
[artifact:mvn] [INFO] task-segment: [org.apache.maven.plugins:maven-gpg-plugin:1.1:sign-and-deploy-file] (aggregator-style)
[artifact:mvn] [INFO] ------------------------------------------------------------------------
[artifact:mvn] [INFO] [gpg:sign-and-deploy-file]
[artifact:mvn] [INFO] Retrieving previous build number from sonatype-nexus-snapshots
[artifact:mvn] Uploading: https://oss.sonatype.org/content/repositories/snapshots//org/scalatest/scalatest_2.9.0/1.8-SNAPSHOT/scalatest_2.9.0-1.8-SNAPSHOT.jar
[artifact:mvn] 2776K uploaded
[artifact:mvn] [INFO] ------------------------------------------------------------------------
[artifact:mvn] [ERROR] BUILD ERROR
[artifact:mvn] [INFO] ------------------------------------------------------------------------
[artifact:mvn] [INFO] Error deploying artifact: Authorization failed: Access denied to: https://oss.sonatype.org/content/repositories/snapshots//org/scalatest/scalatest_2.9.0/1.8-SNAPSHOT/scalatest_2.9.0-1.8-SNAPSHOT.jar

I've attached my pom.xml file.

Here's an expunged version of what I have in my ~/.m2/settings.xml file:

<settings>
<servers>
<server>
<id>sonatype-nexus-snapshots</id>
<username>myusername</username>
<password>mypassword</password>
</server>
<server>
<id>sonatype-nexus-staging</id>
<username>myusername</username>
<password>mypassword</password>
</server>
</servers>

The username and password I put in here is the one I can use to log into issues.sonatype.org.



 Comments   
Comment by Viktor Kazakov [ 04/09/12 ]

Bill, did you solve it somehow?

Comment by Joel Orlina [ 04/09/12 ]

Is this still happening? If so, does this document help:

http://www.sonatype.com/people/2010/11/what-to-do-when-nexus-returns-401/

Comment by Viktor Kazakov [ 04/09/12 ]

Oh, I was wrong, in fact I get 403 Forbidden. That's another story, I guess... Thanks for the link!

Comment by Joel Orlina [ 04/09/12 ]

Viktor,

If you need deployer rights for this project, please have Bill Venners comment on this issue with his authorization.

Generated at Sun Nov 19 22:01:05 UTC 2017 using JIRA 7.3.3#73014-sha1:d5be8da522213be2ca9ad7b043c51da6e4cc9754.