[NEXUS-4453] Nexus won't start running under jdk7 Created: 08/05/11  Updated: 08/08/11  Resolved: 08/08/11

Status: Closed
Project: Dev - Nexus Repo
Component/s: None
Affects Version/s: 1.9.2
Fix Version/s: None

Type: Bug Priority: Major
Reporter: Jens Ritter Assignee: Unassigned
Resolution: Duplicate Votes: 1
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified
Environment:

Debian GNU/Linux 6.0 - 2.6.32-5-amd64


Issue Links:
Duplicate
duplicates NEXUS-4437 Can't start Nexus 1.9.2 with Java 7 Closed
Last Updated By: Rich Seddon

 Description   

Running under
java version "1.7.0"
Java(TM) SE Runtime Environment (build 1.7.0-b147)
Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)

Nexus won't start. Its stopping with this error-message :
jvm 1 | ---- Debugging information ----
jvm 1 | message : Cannot construct org.codehaus.plexus.util.xml.Xpp3Dom as it does not have a no-args constructor
jvm 1 | cause-exception : com.thoughtworks.xstream.converters.reflection.ObjectAccessException
jvm 1 | cause-message : Cannot construct org.codehaus.plexus.util.xml.Xpp3Dom as it does not have a no-args constructor
jvm 1 | class : org.sonatype.nexus.configuration.model.Configuration
jvm 1 | required-type : org.codehaus.plexus.util.xml.Xpp3Dom
jvm 1 | path : /org.sonatype.nexus.configuration.model.Configuration/repositories/org.sonatype.nexus.configuration.model.CRepository/externalConfiguration
jvm 1 | line number : 40
jvm 1 | -------------------------------

( workaround : switching to jdk 1.6_26 let's me run nexus - without any problems )


Generated at Fri Aug 17 15:04:35 UTC 2018 using JIRA 7.3.3#73014-sha1:d5be8da522213be2ca9ad7b043c51da6e4cc9754.