Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 0.11.0
    • Fix Version/s: None
    • Component/s: None
    • Global Rank:
      3313

      Description

      I have a maven/tycho experiment with 2 orion server features at git://git.eclipse.org/gitroot/e4/org.eclipse.orion.server.git in the mavenExperiment branch.

      If I check it out and cd to org.eclipse.orion.server/releng/org.eclipse.orion.server.aggregator I can run a mvn clean install and in ../org.eclipse.orion.server.repository (my eclipse-repository directory) it creates a valid p2 repo.

      If I stay in the aggregator and run mvn clean install again it fails out with lots of compile errors. The bundles published to my local repository in $HOME/.m2/repository/org/eclipse/orion seem to be interfering with the second build. If I delete the $HOME/.m2/repository/org/eclipse/orion directory the build is once again successful.

        Activity

        Jan Sievers added a comment -

        attached patch fixes the problem. bin.includes was missing a dot '.' which lead to no classes being included in the bundle jar.
        What we need to check though is why the bundle jar from the local repo took precedence over the maven reactor local one. The reactor-local project should win.

        Paul Webster added a comment -

        Thanx Jan, I've opened https://bugs.eclipse.org/bugs/show_bug.cgi?id=341143 for us to fix that.

        PW

        Paul Webster added a comment -

        Just a note, with the fix in our build.properties the second and third mvn clean install also create a broken repo, with potentially a missing feature and with the orion plugins missing.

        PW

        Jan Sievers added a comment -

        Paul,

        I can reproduce the problem with the missing feature/plugins; it happens on second and following builds only.

        I found that when I remove the leading 'v' in

        <configuration>
        <format>'v'yyyyMMdd-HHmm</format>
        </configuration>

        (or just remove the custom format altogether), the problem goes away. This means that somehow tycho gets confused by the qualifier format used.
        In principle I don't see a problem with your custom format, but for now it seems tycho does not handle it correctly.

        We need to to dig further into the problem but I could imagine there are places in the code where we hardcoded the default format or maybe we implicitly assumed it starts with a digit or something similar.

        Igor Fedorenko added a comment -

        This is the same problem as https://bugs.eclipse.org/bugs/show_bug.cgi?id=342637 .

        Due to 342637, tycho target platform resolver compares literal '.qualifier' version qualifier of reactor projects with '.v20110329-1234' expanded version qualifier artifacts installed to maven local repository during. 'v' comes after 'q', so locally installed (and broken) artifact wins.

        The problem is fixed in Tycho 0.11.1-SNAPSHOT, which will ignore external dependencies that have the same IU ID as reactor projects.


          People

          • Assignee:
            Igor Fedorenko
            Reporter:
            Paul Webster
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: