Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not A Bug
    • Labels:
      None
    • Global Rank:
      15856

      Description

      I get the following errors when trying to deploy snapshots or releases:


      > mvn gpg:sign-and-deploy-file -Durl=https://oss.sonatype.org/service/local/staging/deploy/maven2/ -DrepositoryId=sonatype-nexus-stagi
      ng -DpomFile=dist/gbench-0.2.0.pom -Dfile=dist/gbench-0.2.0.jar
      [INFO] Scanning for projects...
      [INFO]
      [INFO] ------------------------------------------------------------------------
      [INFO] Building Maven Stub Project (No POM) 1
      [INFO] ------------------------------------------------------------------------
      [INFO]
      [INFO] — maven-gpg-plugin:1.3:sign-and-deploy-file (default-cli) @ standalone-pom —
      GPG Passphrase: ************
      *gpg: WARNING: "--no-use-agent" is an obsolete option - it has no effect
      gpg: WARNING: "--no-use-agent" is an obsolete option - it has no effect
      Uploading: https://oss.sonatype.org/service/local/staging/deploy/maven2/com/google/gbench/gbench/0.2.0/gbench-0.2.0.jar
      Uploading: https://oss.sonatype.org/service/local/staging/deploy/maven2/com/google/gbench/gbench/0.2.0/gbench-0.2.0.pom
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 10.030s
      [INFO] Finished at: Thu Jul 21 04:55:46 JST 2011
      [INFO] Final Memory: 6M/19M
      [INFO] ------------------------------------------------------------------------
      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-gpg-plugin:1.3:sign-and-deploy-file (default-cli) on project standalone-
      pom: Failed to deploy artifacts: Could not transfer artifact com.google.gbench:gbench:jar:0.2.0 from/to sonatype-nexus-staging (https:
      //oss.sonatype.org/service/local/staging/deploy/maven2/): Failed to transfer file: https://oss.sonatype.org/service/local/staging/depl
      oy/maven2/com/google/gbench/gbench/0.2.0/gbench-0.2.0.jar. Return code is: 401 -> [Help 1]
      [ERROR]
      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
      [ERROR] Re-run Maven using the -X switch to enable full debug logging.
      [ERROR]
      [ERROR] For more information about the errors and possible solutions, please read the following articles:
      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException


        Activity

        Juven Xu added a comment -

        server config looks ok, can you verify your settings.xml is configured correctly?

        this post might be able to provide some help: http://www.sonatype.com/people/2010/11/what-to-do-when-nexus-returns-401/

        Nagai Masato added a comment -

        settings.xml nerver changed since the last time when I succeeded to deploy and I can
        log into Nexus UI with username/password in it.

        Juven Xu added a comment -

        can you provide more details? like the output of mvn help:effective-settings

        Nagai Masato added a comment -

        Sure.

        > mvn help:effective-settings -f gbench-0.2.0.pom
        [INFO] Scanning for projects...
        [INFO]
        [INFO] ------------------------------------------------------------------------
        [INFO] Building GBench 0.2.0
        [INFO] ------------------------------------------------------------------------
        [INFO]
        [INFO] — maven-help-plugin:2.1.1:effective-settings (default-cli) @ gbench —
        [INFO]
        Effective user-specific configuration settings:

        <?xml version="1.0" encoding="UTF-8"?>
        <!-- ====================================================================== -->
        <!-- -->
        <!-- Generated by Maven Help Plugin on 2011-07-23T08:49:33 -->
        <!-- See: http://maven.apache.org/plugins/maven-help-plugin/ -->
        <!-- -->
        <!-- ====================================================================== -->

        <!-- ====================================================================== -->
        <!-- -->
        <!-- Effective Settings for 'Masato' on 'XXXXXXXXX' -->
        <!-- -->
        <!-- ====================================================================== -->

        <settings xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://m
        aven.apache.org/SETTINGS/1.1.0 http://maven.apache.org/xsd/settings-1.1.0.xsd">
        <localRepository xmlns="http://maven.apache.org/SETTINGS/1.1.0">C:\Users\Masato\.m2\repository</localRepository>
        <servers xmlns="http://maven.apache.org/SETTINGS/1.1.0">
        <server>
        <username>nagaimasato</username>
        <password>***</password>
        <id>sonatype-nexus-snapshots</id>
        </server>
        <server>
        <username>nagaimasato</username>
        <password>***</password>
        <id>sonatype-nexus-staging</id>
        </server>
        </servers>
        <pluginGroups xmlns="http://maven.apache.org/SETTINGS/1.1.0">
        <pluginGroup>org.apache.maven.plugins</pluginGroup>
        <pluginGroup>org.codehaus.mojo</pluginGroup>
        </pluginGroups>
        </settings>

        [INFO] ------------------------------------------------------------------------
        [INFO] BUILD SUCCESS
        [INFO] ------------------------------------------------------------------------
        [INFO] Total time: 0.820s
        [INFO] Finished at: Sat Jul 23 08:49:33 JST 2011
        [INFO] Final Memory: 6M/15M
        [INFO] ------------------------------------------------------------------------

        Nagai Masato added a comment -

        Uploading via Nexus UI also fails with "illegal access of staging profile" error. What does it mean?

        Juven Xu added a comment -

        ok, I got it, it's because you are using incorrect groupId (com.google.gbench), you will to update it to com.googlecode.gbench

        lemme know if it works, thanks

        Nagai Masato added a comment -

        Ah.. you're right. I succeeded to deploy the artifacts by fixing the group ID.
        Sorry, I'm so embarrassed...

        Juven Xu added a comment -

        np, closing ticket


          People

          • Assignee:
            Juven Xu
            Reporter:
            Nagai Masato
            Last Updated By:
            Juven Xu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: