Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-9353

bin/nexus-run helper app does not function if installer had unselected service start

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-m6
    • Fix Version/s: 3.0.0-m6
    • Component/s: Installer
    • Labels:
      None
    • Environment:
      CentOS GNOME; (MacOSX)
    • Story Points:
      0.5
    • Sprint:
      Sprint 54

      Description

      While testing the installer, I ran a basic setup but unchecked 'Start service' from the advanced options (Service tab).
      At the end "Completing the Sonatype Nexus Setup Wizard", I kept 'Create Desktop Icons' checked.
      When I double clicked the icon, I got the attached errors (one on screen, the other in console log).
      I first noticed this on Mac running the .sh file, then subsequently in Linux CentOS GNOME. I was unable to test this in CentOS KDE due to an error with the icon not creating.

      These errors occur regardless of if Nexus is started or not.
      Running with start service checked seems to work.

        Attachments

          Activity

            People

            Assignee:
            jtom Joe Tom
            Reporter:
            jtom Joe Tom
            Last Updated By:
            Peter Lynch Peter Lynch
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Date of First Response:

                tigCommentSecurity.panel-title