Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-9351

Logger related(?) error at top of console after reset

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-m6
    • Fix Version/s: 3.0.0-m6
    • Component/s: Support Tools
    • Labels:
      None
    • Environment:
      (MacOSX)
    • Story Points:
      0.5
    • Sprint:
      Sprint 54

      Description

      I noticed this line at the top of my nexus.log when I restarted my nexus:
      'ERROR in ch.qos.logback.core.joran.action.PropertyAction - In <property> element, either the "file" attribute alone, or the "resource" element alone, or both the "name" and "value" attributes must be set.'

      Earlier I had rebuilt and written up NEXUS-9350 and not done anything else noteworthy. I was subsequently able to repro this by building a new nexus, starting it, resetting logs to default level and restarting nexus.
      As far as I could tell this did not occur on the initial post-install start.

      I did not check older NX3 or NX2 at this time.
      Debug was off during this test.

        Attachments

        1. logback.xml
          2 kB
        2. logback-overrides.xml
          0.2 kB
        3. nexus.log
          73 kB
        4. snip.txt
          35 kB

          Activity

            People

            Assignee:
            jtom Joe Tom
            Reporter:
            jtom Joe Tom
            Last Updated By:
            Peter Lynch Peter Lynch
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Date of First Response:

                tigCommentSecurity.panel-title