Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-9286

Specific actions in search can cause list not to load

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.0.0-m6
    • Fix Version/s: None
    • Component/s: Search, UI
    • Labels:
      None
    • Environment:
      Chrome, FF, Safari MacOSX
    • Story Points:
      3
    • Sprint:
      Sprint 58 - Föhn

      Description

      When testing npm, I just noticed a very similar thing to NEXUS-9109 (pre-fix).
      I had a bunch of npm components and was doing a non-custom keyword search. Searching for "test" shows over a page worth of component results. I searched for "testproject1" and there was one result (as expected, I had created it). Limiting to "testp" shows no results (because of lack of wildcard/* - aka NEXUS-8884). However, then limiting back to "test" seemed to show no results. After a couple times reproing this, I noticed a scroll on the right side.
      This occurs despite the fix for NEXUS-9109.
      See attached vids.

      Setup/config steps:
      //setup of data
      1) Setup your npm instance as https://docs.sonatype.com/display/Nexus/NPM+Testing (.npmrc edits and nexus repos). WARN: Due to not committed fix turn strict content validation off for Proxy or step 4 will fail to build.
      2) Download user package from https://issues.sonatype.org/browse/NEXUS-8043 and unzip
      3) From that directory, run Kelly's script (https://gist.github.com/kellyrob99/8e86227da5c8fd7d7a30) to get everything into Nexus Hosted. NOTE: This takes a while. Some will error but most should go through = "+

      {package}

      " [no errors or subsequent/following lines]. Can recheck browse assets/components for npmhosted if you're unsure.
      4) Following https://docs.sonatype.com/display/Nexus/NPM+Testing, test hosted and proxy. Note repository differences in configuration of package local. This further populates each repo; I did 2 hosted tests. Let me know if you need more details here. Trying not to retype what's already documented
      //performing bug (as vid)
      5) Go to Search
      6) Type in "test"
      7) After results, adjust to "testproject1" (or whatever you named your hosted package)
      8) After result, adjust to "testp". Should see no results because of lack of wildcard symbol.
      9) After a few seconds, adjust to "test". No results show. Scroll shows (on my machine/setup). Scrolling reveals results.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              shenty Steve Henty
              Reporter:
              jtom Joe Tom
              Last Updated By:
              Peter Lynch
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response:

                  tigCommentSecurity.panel-title