Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-8520

Roles: Saving nullifies filter but does not clear filter text

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-m4, 3.7.0
    • Fix Version/s: 3.14.0
    • Component/s: Security, UI
    • Labels:
      None
    • Environment:
      Chrome MacOSX

      Description

      I noticed that while on the Roles page editing a role, you can successfully filter by role and by privilege however on save the filtering stops. This might be as intended but the filter words are NOT cleared leaving a disjoint in appearance.
      See attached (it appears I am filtering by joe but in fact I am filtering by nothing) - let me know if unclear and I'll take a vid.
      Pre-save is fine, if you filter again it's fine, if you refresh it's fine. So plenty of workarounds but behavior could be better.
      It'd surprise me if this was the only place with this issue...if I see elsewhere I'll add here (assuming still open).

      I did not check older versions of NX3 or NX2 at this time. I do not believe this in any way has to do with the discovered while link but linking for thoroughness.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              jtom Joe Tom
              Last Updated By:
              Peter Lynch Peter Lynch
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response:

                  tigCommentSecurity.panel-title