Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-7996

Users: Changing dropdown does not show list until refresh

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.11.2, 3.0.0-m3, 3.0.0-m4, 3.0.0, 3.1.0, 3.9.0, 3.10.0
    • Fix Version/s: 3.15.0
    • Component/s: Security, UI
    • Labels:
    • Environment:
      Chrome, FF, Safari MacOSX & Chrome, IE11 Windows7
    • Story Points:
      2

      Description

      In NX3 Cowbell SNAPSHOT, I noticed that on the users page, when I changed from "Default" to "All Configured Users" the 2nd list was empty.
      After review, I found that the list would show contents if I refreshed (via the button on the page, not the browser).
      I checked NX2 and the same behavior seems to occur except that the dropdown defaults to "All Configured Users" but shows no contents when switching to "All Users" (for example).

      Attaching screen (of server with all 3 default users; NX3), let me know if unclear, and I can do a movie.

      Acceptance Criteria:

      • When changing dropdown, refresh and display all users who are in results of the new dropdown selected.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              elijahel Elijah El-Haddad
              Reporter:
              jtom Joe Tom
              Last Updated By:
              Peter Lynch
              Team:
              NXRM - Tron
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response:

                  tigCommentSecurity.panel-title