Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-7963

Rapture gets confused about users being able to log in but having no "UI permission"

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.0.0-m3
    • Fix Version/s: None
    • Component/s: UI
    • Labels:
      None

      Description

      While testing LDAP, I found following problem:
      1) set up LDAP server, put it 1st in Realm order
      2) I forgot to set up user mapping, hence users from LDAP were able to authc, but authz had no (or better, LDAP roles were unknown to NX)
      3) logged in as LDAP user: UI told me "I have no permissions to use UI", login screeen returned on every enter, only way to "escape" was reload the UI
      4) when reloaded, LDAP user was displayed in upper right corner, but had no UI elements: kinda I was "in", but could not access any of the UI

      I'd expect that if user have no UI perms, to be kicked out from UI. Affects Nx3 Rapture UI.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            cstamas Tamás Cservenák
            Last Updated By:
            Peter Lynch Peter Lynch
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Date of First Response:

                tigCommentSecurity.panel-title