Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-7615

add support for npm deprecate

    Details

    • Type: Story
    • Status: Done
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.10
    • Fix Version/s: 3.0.0-m6
    • Component/s: NPM, UI
    • Labels:
      None

      Description

      Acceptance Criteria:

      • Add and test support for the ability to use the npm deprecate command to deprecate a package
      • Add and test support for the ability to use the npm deprecate command to UNdeprecate a package
      • Visually show that the package has been deprecated in Search and Browse

      This is the alternative for npm unpublish ( NEXUS-6892 )

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              dsauble Daniel Sauble
              Reporter:
              plynch Peter Lynch
              Last Updated By:
              Joe Tom Joe Tom
              Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response:

                  tigCommentSecurity.panel-title