Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-6300

Support for OpenJDK as runtime

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0-m3
    • Fix Version/s: 3.15.0
    • Component/s: Configuration
    • Labels:
      None

      Description

      Give that OpenJDK is the reference platform for new Java/JDK development and the default JDK on Linux we should support running Nexus with OpenJDK 7.

      Acceptance

      • We should validate that our product can be built and run with the presently supported (Java8) and latest (Java11) versions of OpenJDK
      • update infrastructure to test latest OpenJDK (and discuss support for testing intermediate versions?)
      • update documentation to reflect Java support changes

       

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              dsawa Dawid Sawa
              Reporter:
              simpligility Manfred Moser
              Last Updated By:
              Peter Lynch
              Votes:
              10 Vote for this issue
              Watchers:
              14 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response:

                  tigCommentSecurity.panel-title