Uploaded image for project: 'Dev - Nexus'
  1. Dev - Nexus
  2. NEXUS-5852

Add Common JS Package Registry / node.js / NPM support

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.9
    • Fix Version/s: 2.10
    • Component/s: NPM, Repository
    • Labels:
      None
    • Sprint:
      Sprint 26

      Description

      Implement the ability to proxy and host repositories in this format.

      http://wiki.commonjs.org/wiki/Packages/Registry

      This would then allow Nexus to have interoperability with NODE Package Manager (NPM).

        Activity

        jdillon Jason Dillon added a comment -

        Marcello de Sales please open new issues for anything else you find, do not create subtasks on this issue please.

        marcellodesales Marcello de Sales added a comment -

        Not a problem @dillon... I don't have permissions to your Jira, but you can move those subtasks as any other Jira type...

        Thanks!

        gerald.garcia Gerald added a comment - - edited

        I was able to publish my package but Nexus is not displaying the packages I have published. Unable to view using the Browse Storage Tab.

        I noticed my packages were inside a " - " named folder. Is this the possible cause? How to remove/change the " - " folder?

        Many Thanks!

        plynch Peter Lynch added a comment -

        Gerald Browse Storage is not enabled by design in the initial release.

        You can instead see content by navigating to
        https://localhost:8081/nexus/content/repositories/<hosted-repo-id>/

        > I noticed my packages were inside a " - " named folder. Is this the possible cause? How to remove/change the " - " folder?

        The - folder is part of the url that is requested by npm client. This is standard npm design.

        gerald.garcia Gerald added a comment -

        Peter Lynch Thanks! Understood the - folder is standard npm design. I think, I'll just wait for the Browse Storage to be enabled.

        For now I'll just navigate to the <hosted-repo-id>/-/ (with - at the end; I'm only seeing the npm json if w/o - )
        https://localhost:8081/nexus/content/repositories/<hosted-repo-id>/-/

        Many Thanks!


          People

          • Assignee:
            cstamas Tamás Cservenák
            Reporter:
            plynch Peter Lynch
            Last Updated By:
            Brian Fox
          • Votes:
            64 Vote for this issue
            Watchers:
            45 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response:

              Agile