Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: 1.9.2.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Global Rank:
      7547

      Description

      When trying to deploy nexus on JBoss 7.0.1 (web-profile) I get this error:
      2011-08-30 12:06:19 WARN [vice thread 1-2] - org.sonatype.guice.bean.reflect.NamedClass - Error injecting: org.sonatype.nexus.DefaultNexus
      com.google.inject.ProvisionException: Guice provision errors:

      1) No implementation for org.sonatype.nexus.plugins.NexusPluginManager was bound.
      while locating org.sonatype.nexus.DefaultNexus

      2) Error notifying InjectionListener org.sonatype.guice.plexus.binders.PlexusBeanBinder@833c9 of org.sonatype.nexus.DefaultNexus.
      Reason: java.lang.NullPointerException
      while locating org.sonatype.nexus.DefaultNexus

      2 errors
      at com.google.inject.internal.InjectorImpl$4.get(InjectorImpl.java:977)
      at com.google.inject.internal.InjectorImpl.getInstance(InjectorImpl.java:1003)
      at org.sonatype.guice.bean.reflect.AbstractDeferredClass.get(AbstractDeferredClass.java:47)
      at com.google.inject.internal.InternalFactoryToProviderAdapter.get(InternalFactoryToProviderAdapter.java:40)
      at com.google.inject.internal.ProviderToInternalFactoryAdapter$1.call(ProviderToInternalFactoryAdapter.java:46)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1021)
      at com.google.inject.internal.ProviderToInternalFactoryAdapter.get(ProviderToInternalFactoryAdapter.java:40)
      at com.google.inject.Scopes$1$1.get(Scopes.java:59)
      at com.google.inject.internal.InternalFactoryToProviderAdapter.get(InternalFactoryToProviderAdapter.java:40)
      at com.google.inject.internal.InjectorImpl$4$1.call(InjectorImpl.java:968)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1014)
      at com.google.inject.internal.InjectorImpl$4.get(InjectorImpl.java:964)
      at org.sonatype.guice.bean.locators.LazyBeanEntry.getValue(LazyBeanEntry.java:79)
      at org.sonatype.guice.plexus.locators.LazyPlexusBean.getValue(LazyPlexusBean.java:53)
      at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:243)
      at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:235)
      at org.codehaus.plexus.DefaultPlexusContainer.lookup(DefaultPlexusContainer.java:229)
      at org.sonatype.nexus.web.NexusBooterListener.contextInitialized(NexusBooterListener.java:48)
      at org.apache.catalina.core.StandardContext.contextListenerStart(StandardContext.java:3368)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:3821)
      at org.jboss.as.web.deployment.WebDeploymentService.start(WebDeploymentService.java:70)
      at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1765)
      at org.jboss.msc.service.ServiceControllerImpl$ClearTCCLTask.run(ServiceControllerImpl.java:2291)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: java.lang.NullPointerException
      at org.sonatype.nexus.DefaultNexus.initialize(DefaultNexus.java:618)
      at org.codehaus.plexus.PlexusLifecycleManager.initialize(PlexusLifecycleManager.java:285)
      at org.codehaus.plexus.PlexusLifecycleManager.manageLifecycle(PlexusLifecycleManager.java:247)
      at org.codehaus.plexus.PlexusLifecycleManager.manage(PlexusLifecycleManager.java:154)
      at org.sonatype.guice.plexus.binders.PlexusBeanBinder.afterInjection(PlexusBeanBinder.java:78)
      at com.google.inject.internal.MembersInjectorImpl.notifyListeners(MembersInjectorImpl.java:97)
      at com.google.inject.internal.ConstructorInjector.construct(ConstructorInjector.java:95)
      at com.google.inject.internal.ConstructorBindingImpl$Factory.get(ConstructorBindingImpl.java:254)
      at com.google.inject.internal.InjectorImpl$4$1.call(InjectorImpl.java:968)
      at com.google.inject.internal.InjectorImpl.callInContext(InjectorImpl.java:1021)
      at com.google.inject.internal.InjectorImpl$4.get(InjectorImpl.java:964)
      ... 25 more

      To get nexus.war to deploy successfully one has to apply the workarround mentinoned in https://issues.jboss.org/browse/AS7-1564

      1. nexus.log
        69 kB
        Burkhard Vogel

        Issue Links

          Activity

          Tamás Cservenák added a comment -

          FYI, the use of System.out is fixed in Nexus 2.1 (current master branch), where AppContext – the component doing that dump (the "Application context "nexus" dump:" etc) to the System.out will detect presence of Slf4j on classpath and use it if found. It will "fallback" to System.out only as "last resort".

          Hendy Irawan added a comment -

          Issue in JBoss AS7 JIRA : https://issues.jboss.org/browse/AS7-3765

          Mauro Flores added a comment -

          It is getting the following error on JBoss AS 7.0.2

          Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.codehaus.jackson.map.ObjectMapper

          com.google.inject.ProvisionException: Guice provision errors:

          1) Error injecting constructor, java.lang.NoSuchMethodError: org.codehaus.jackson.type.JavaType.<init>(Ljava/lang/Class;I)V
          2) Error injecting constructor, java.lang.NoClassDefFoundError: Could not initialize class org.codehaus.jackson.map.ObjectMapper

          Samuel Tauil added a comment -

          I'm getting this error using nexus-2.0.4-1.war in JBoss AS 7.1.1.Final
          Seems that only works in servlet containers.

          [samuel@karranca bin]$ ./standalone.sh
          =========================================================================

          JBoss Bootstrap Environment

          JBOSS_HOME: /opt/appservers/jboss-as-7.1.1.Final

          JAVA: /etc/alternatives/java_sdk/bin/java

          JAVA_OPTS: -server -XX:+UseCompressedOops -XX:+TieredCompilation -Xms64m -Xmx512m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Dorg.jboss.resolver.warning=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true -Djboss.server.default.config=standalone.xml

          =========================================================================

          15:27:57,306 INFO [org.jboss.modules] JBoss Modules version 1.1.1.GA
          15:27:58,260 INFO [org.jboss.msc] JBoss MSC version 1.0.2.GA
          15:27:58,387 INFO [org.jboss.as] JBAS015899: JBoss AS 7.1.1.Final "Brontes" starting
          15:28:02,727 INFO [org.xnio] XNIO Version 3.0.3.GA
          15:28:02,730 INFO [org.jboss.as.server] JBAS015888: Creating http management service using socket-binding (management-http)
          15:28:02,801 INFO [org.xnio.nio] XNIO NIO Implementation Version 3.0.3.GA
          15:28:02,835 INFO [org.jboss.remoting] JBoss Remoting version 3.2.3.GA
          15:28:02,889 INFO [org.jboss.as.logging] JBAS011502: Removing bootstrap log handlers
          15:28:02,916 INFO [org.jboss.as.configadmin] (ServerService Thread Pool – 32) JBAS016200: Activating ConfigAdmin Subsystem
          15:28:03,050 INFO [org.jboss.as.osgi] (ServerService Thread Pool – 49) JBAS011940: Activating OSGi Subsystem
          15:28:03,052 INFO [org.jboss.as.jacorb] (ServerService Thread Pool – 38) JBAS016300: Activating JacORB Subsystem
          15:28:03,052 INFO [org.jboss.as.clustering.infinispan] (ServerService Thread Pool – 37) JBAS010280: Activating Infinispan subsystem.
          15:28:03,049 INFO [org.jboss.as.webservices] (ServerService Thread Pool – 58) JBAS015537: Activating WebServices Extension
          15:28:03,057 INFO [org.jboss.as.security] (ServerService Thread Pool – 54) JBAS013101: Activating Security Subsystem
          15:28:03,091 INFO [org.jboss.as.naming] (ServerService Thread Pool – 48) JBAS011800: Activating Naming Subsystem
          15:28:03,476 INFO [org.jboss.as.security] (MSC service thread 1-7) JBAS013100: Current PicketBox version=4.0.7.Final
          15:28:03,716 INFO [org.jboss.as.connector] (MSC service thread 1-4) JBAS010408: Starting JCA Subsystem (JBoss IronJacamar 1.0.9.Final)
          15:28:04,297 INFO [org.jboss.as.naming] (MSC service thread 1-3) JBAS011802: Starting Naming Service
          15:28:04,432 INFO [org.jboss.as.mail.extension] (MSC service thread 1-5) JBAS015400: Bound mail session [java:jboss/mail/Default]
          15:28:04,777 INFO [org.jboss.jaxr] (MSC service thread 1-2) JBAS014000: Started JAXR subsystem, binding JAXR connection factory into JNDI as: java:jboss/jaxr/ConnectionFactory
          15:28:05,033 INFO [org.jboss.as.connector.subsystems.datasources] (ServerService Thread Pool – 33) JBAS010403: Deploying JDBC-compliant driver class org.h2.Driver (version 1.3)
          15:28:05,537 INFO [org.jboss.ws.common.management.AbstractServerConfig] (MSC service thread 1-4) JBoss Web Services - Stack CXF Server 4.0.2.GA
          15:28:05,648 INFO [org.apache.coyote.http11.Http11Protocol] (MSC service thread 1-6) Starting Coyote HTTP/1.1 on http--0.0.0.0-8080
          15:28:05,836 INFO [org.jboss.as.jacorb] (MSC service thread 1-1) JBAS016330: CORBA ORB Service started
          15:28:06,131 INFO [org.hornetq.core.server.impl.HornetQServerImpl] (MSC service thread 1-5) live server is starting with configuration HornetQ Configuration (clustered=false,backup=false,sharedStore=true,journalDirectory=/opt/appservers/jboss-as-7.1.1.Final/standalone/data/messagingjournal,bindingsDirectory=/opt/appservers/jboss-as-7.1.1.Final/standalone/data/messagingbindings,largeMessagesDirectory=/opt/appservers/jboss-as-7.1.1.Final/standalone/data/messaginglargemessages,pagingDirectory=/opt/appservers/jboss-as-7.1.1.Final/standalone/data/messagingpaging)
          15:28:06,133 INFO [org.hornetq.core.server.impl.HornetQServerImpl] (MSC service thread 1-5) Waiting to obtain live lock
          15:28:06,173 INFO [org.jboss.as.jacorb] (MSC service thread 1-7) JBAS016328: CORBA Naming Service started
          15:28:06,191 INFO [org.hornetq.core.persistence.impl.journal.JournalStorageManager] (MSC service thread 1-5) Using AIO Journal
          15:28:06,705 INFO [org.jboss.as.server.deployment.scanner] (MSC service thread 1-7) JBAS015012: Started FileSystemDeploymentService for directory /opt/appservers/jboss-as-7.1.1.Final/standalone/deployments
          15:28:06,708 INFO [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) JBAS015014: Re-attempting failed deployment jaasexample.war
          15:28:06,785 INFO [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) JBAS015014: Re-attempting failed deployment form-auth.war
          15:28:06,787 INFO [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) JBAS015003: Found jaasexample.war in deployment directory. To trigger deployment create a file called jaasexample.war.dodeploy
          15:28:06,833 INFO [org.jboss.as.remoting] (MSC service thread 1-4) JBAS017100: Listening on /127.0.0.1:9999
          15:28:06,834 INFO [org.jboss.as.remoting] (MSC service thread 1-7) JBAS017100: Listening on 0.0.0.0/0.0.0.0:4447
          15:28:07,233 INFO [org.hornetq.core.server.impl.AIOFileLockNodeManager] (MSC service thread 1-5) Waiting to obtain live lock
          15:28:07,234 INFO [org.hornetq.core.server.impl.AIOFileLockNodeManager] (MSC service thread 1-5) Live Server Obtained live lock
          15:28:07,369 INFO [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-2) JBAS010400: Bound data source [java:jboss/datasources/ExampleDS]
          15:28:08,037 INFO [org.hornetq.core.remoting.impl.netty.NettyAcceptor] (MSC service thread 1-5) Started Netty Acceptor version 3.2.5.Final-a96d88c 0.0.0.0:5455 for CORE protocol
          15:28:08,044 INFO [org.hornetq.core.remoting.impl.netty.NettyAcceptor] (MSC service thread 1-5) Started Netty Acceptor version 3.2.5.Final-a96d88c 0.0.0.0:5445 for CORE protocol
          15:28:08,047 INFO [org.hornetq.core.server.impl.HornetQServerImpl] (MSC service thread 1-5) Server is now live
          15:28:08,048 INFO [org.hornetq.core.server.impl.HornetQServerImpl] (MSC service thread 1-5) HornetQ Server version 2.2.13.Final (HQ_2_2_13_FINAL_AS7, 122) [d1a9841d-a389-11e1-b88f-c80aa9db1060]) started
          15:28:08,054 INFO [org.hornetq.core.server.impl.HornetQServerImpl] (MSC service thread 1-5) trying to deploy queue jms.queue.testQueue
          15:28:08,069 INFO [org.jboss.as.messaging] (MSC service thread 1-5) JBAS011601: Bound messaging object to jndi name java:/queue/test
          15:28:08,075 INFO [org.jboss.as.messaging] (MSC service thread 1-5) JBAS011601: Bound messaging object to jndi name java:jboss/exported/jms/queue/test
          15:28:08,076 INFO [org.hornetq.core.server.impl.HornetQServerImpl] (MSC service thread 1-7) trying to deploy queue jms.topic.testTopic
          15:28:08,177 INFO [org.jboss.as.messaging] (MSC service thread 1-7) JBAS011601: Bound messaging object to jndi name java:/topic/test
          15:28:08,178 INFO [org.jboss.as.messaging] (MSC service thread 1-7) JBAS011601: Bound messaging object to jndi name java:jboss/exported/jms/topic/test
          15:28:08,202 INFO [org.jboss.as.messaging] (MSC service thread 1-8) JBAS011601: Bound messaging object to jndi name java:jboss/exported/jms/RemoteConnectionFactory
          15:28:08,204 INFO [org.jboss.as.messaging] (MSC service thread 1-8) JBAS011601: Bound messaging object to jndi name java:/RemoteConnectionFactory
          15:28:08,207 INFO [org.jboss.as.deployment.connector] (MSC service thread 1-3) JBAS010406: Registered connection factory java:/JmsXA
          15:28:08,207 INFO [org.jboss.as.messaging] (MSC service thread 1-2) JBAS011601: Bound messaging object to jndi name java:/ConnectionFactory
          15:28:08,228 INFO [org.hornetq.ra.HornetQResourceAdapter] (MSC service thread 1-3) HornetQ resource adaptor started
          15:28:08,229 INFO [org.jboss.as.connector.services.ResourceAdapterActivatorService$ResourceAdapterActivator] (MSC service thread 1-3) IJ020002: Deployed: file://RaActivatorhornetq-ra
          15:28:08,232 INFO [org.jboss.as.deployment.connector] (MSC service thread 1-7) JBAS010401: Bound JCA ConnectionFactory [java:/JmsXA]
          15:28:08,311 INFO [org.jboss.as.server.deployment] (MSC service thread 1-7) JBAS015876: Starting deployment of "form-auth.war"
          15:28:08,311 INFO [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "jaasexample.war"
          15:28:09,335 INFO [org.jboss.web] (MSC service thread 1-3) JBAS018210: Registering web context: /form-auth
          15:28:09,335 INFO [org.jboss.web] (MSC service thread 1-7) JBAS018210: Registering web context: /jaasexample
          15:28:09,366 INFO [org.jboss.as] (MSC service thread 1-4) JBAS015951: Admin console listening on http://127.0.0.1:9990
          15:28:09,366 INFO [org.jboss.as] (MSC service thread 1-4) JBAS015874: JBoss AS 7.1.1.Final "Brontes" started in 13692ms - Started 260 of 343 services (82 services are passive or on-demand)
          15:28:09,521 INFO [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS018559: Deployed "form-auth.war"
          15:28:09,521 INFO [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS018559: Deployed "jaasexample.war"
          15:29:04,557 INFO [org.jboss.as.server.deployment] (MSC service thread 1-2) JBAS015876: Starting deployment of "nexus.war"
          15:29:06,488 WARN [org.jboss.as.server.deployment] (MSC service thread 1-2) Class Path entry activation.jar in "/content/nexus.war/WEB-INF/lib/mail-1.4.jar" does not point to a valid jar for a Class-Path reference.
          15:29:06,538 WARN [org.jboss.as.server.deployment] (MSC service thread 1-6) JBAS015893: Encountered invalid class name 'org.xmlpull.mxp1.MXParser,org.xmlpull.mxp1_serializer.MXSerializer' for service type 'org.xmlpull.v1.XmlPullParserFactory'
          15:29:06,545 INFO [org.jboss.as.pojo] (MSC service thread 1-6) JBAS017000: Found legacy bean/pojo namespace: urn:jboss:bean-deployer:2.0 - might be missing some xml features (potential exceptions).
          15:29:06,911 INFO [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/nexus]] (MSC service thread 1-6) Configuring Nexus in vanilla WAR...
          15:29:06,916 INFO [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/nexus]] (MSC service thread 1-6) Setting Plexus basedir context variable to (discovered from Servlet container): /opt/appservers/jboss-as-7.1.1.Final/standalone/tmp/vfs/tempd0b62f485a89709e/nexus.war-e34d71fd2eecbfd3/WEB-INF
          15:29:06,951 INFO [stdout] (MSC service thread 1-6) ===================================
          15:29:06,951 INFO [stdout] (MSC service thread 1-6) Application context "nexus" dump:
          15:29:06,952 INFO [stdout] (MSC service thread 1-6) "nexus-work"="/home/samuel/sonatype-work/nexus" (raw: "$

          {user.home}

          /sonatype-work/nexus", src: propsFile(/opt/appservers/jboss-as-7.1.1.Final/standalone/tmp/vfs/tempd0b62f485a89709e/nexus.war-e34d71fd2eecbfd3/WEB-INF/plexus.properties, size:5))
          15:29:06,953 INFO [stdout] (MSC service thread 1-6) "runtime"="/opt/appservers/jboss-as-7.1.1.Final/standalone/tmp/vfs/tempd0b62f485a89709e/nexus.war-e34d71fd2eecbfd3/WEB-INF" (raw: "$

          {bundleBasedir}

          ", src: propsFile(/opt/appservers/jboss-as-7.1.1.Final/standalone/tmp/vfs/tempd0b62f485a89709e/nexus.war-e34d71fd2eecbfd3/WEB-INF/plexus.properties, size:5))
          15:29:06,954 INFO [stdout] (MSC service thread 1-6) "application-conf"="/home/samuel/sonatype-work/nexus/conf" (raw: "$

          {nexus-work}/conf", src: propsFile(/opt/appservers/jboss-as-7.1.1.Final/standalone/tmp/vfs/tempd0b62f485a89709e/nexus.war-e34d71fd2eecbfd3/WEB-INF/plexus.properties, size:5))
          15:29:06,955 INFO [stdout] (MSC service thread 1-6) "nexus-app"="/opt/appservers/jboss-as-7.1.1.Final/standalone/tmp/vfs/tempd0b62f485a89709e/nexus.war-e34d71fd2eecbfd3/WEB-INF" (raw: "${runtime}", src: propsFile(/opt/appservers/jboss-as-7.1.1.Final/standalone/tmp/vfs/tempd0b62f485a89709e/nexus.war-e34d71fd2eecbfd3/WEB-INF/plexus.properties, size:5))
          15:29:06,956 INFO [stdout] (MSC service thread 1-6) "security-xml-file"="/home/samuel/sonatype-work/nexus/conf/security.xml" (raw: "${nexus-work}

          /conf/security.xml", src: propsFile(/opt/appservers/jboss-as-7.1.1.Final/standalone/tmp/vfs/tempd0b62f485a89709e/nexus.war-e34d71fd2eecbfd3/WEB-INF/plexus.properties, size:5))
          15:29:06,957 INFO [stdout] (MSC service thread 1-6) "bundleBasedir"="/opt/appservers/jboss-as-7.1.1.Final/standalone/tmp/vfs/tempd0b62f485a89709e/nexus.war-e34d71fd2eecbfd3/WEB-INF" (raw: "/opt/appservers/jboss-as-7.1.1.Final/standalone/tmp/vfs/tempd0b62f485a89709e/nexus.war-e34d71fd2eecbfd3/WEB-INF", src: static("bundleBasedir"="/opt/appservers/jboss-as-7.1.1.Final/standalone/tmp/vfs/tempd0b62f485a89709e/nexus.war-e34d71fd2eecbfd3/WEB-INF"))
          15:29:06,959 INFO [stdout] (MSC service thread 1-6) Total of 6 entries.
          15:29:06,959 INFO [stdout] (MSC service thread 1-6) ===================================
          15:29:06,960 INFO [stdout] (MSC service thread 1-6)
          15:29:15,230 INFO [org.sonatype.scheduling.DefaultScheduler] (MSC service thread 1-6) Shutting down Scheduler...
          15:29:15,232 INFO [org.sonatype.nexus.index.DefaultIndexerManager] (MSC service thread 1-6) Shutting down Nexus IndexerManager
          15:29:15,375 INFO [org.sonatype.plexus.components.ehcache.DefaultEhCacheWrapper] (MSC service thread 1-6) Shutting down EHCache manager.
          15:29:15,388 INFO [org.sonatype.nexus.DefaultNexus] (MSC service thread 1-6) Stopped Nexus (version 2.0.4-1 OSS)
          15:29:15,389 INFO [org.sonatype.nexus.timeline.DefaultNexusTimeline] (MSC service thread 1-6) Stopping Nexus Timeline...
          15:29:16,216 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-6) MSC00001: Failed to start service jboss.web.deployment.default-host./nexus: org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./nexus: JBAS018040: Failed to start context
          at org.jboss.as.web.deployment.WebDeploymentService.start(WebDeploymentService.java:95)
          at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
          at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]
          at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.6.0_24]
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.6.0_24]
          at java.lang.Thread.run(Thread.java:679) [rt.jar:1.6.0_24]

          15:29:16,425 INFO [org.jboss.as.server] (DeploymentScanner-threads - 1) JBAS015870: Deploy of deployment "nexus.war" was rolled back with failure message {"JBAS014671: Failed services" => {"jboss.web.deployment.default-host./nexus" => "org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./nexus: JBAS018040: Failed to start context"}}
          15:29:16,557 INFO [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015877: Stopped deployment nexus.war in 131ms
          15:29:16,558 INFO [org.jboss.as.controller] (DeploymentScanner-threads - 1) JBAS014774: Service status report
          JBAS014777: Services which failed to start: service jboss.web.deployment.default-host./nexus: org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./nexus: JBAS018040: Failed to start context

          15:29:16,559 ERROR [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 2) {"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"JBAS014671: Failed services" => {"jboss.web.deployment.default-host./nexus" => "org.jboss.msc.service.StartException in service jboss.web.deployment.default-host./nexus: JBAS018040: Failed to start context"}}}}

          Jason Dillon added a comment -

          war is not supported. lots has changed since 1.9.x reopen with updated details if still a problem.


            People

            • Assignee:
              Unassigned
              Reporter:
              Burkhard Vogel
            • Votes:
              3 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: