Uploaded image for project: 'Dev - Nexus'
  1. Dev - Nexus
  2. NEXUS-4453

Nexus won't start running under jdk7

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 1.9.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      Debian GNU/Linux 6.0 - 2.6.32-5-amd64

      Description

      Running under
      java version "1.7.0"
      Java(TM) SE Runtime Environment (build 1.7.0-b147)
      Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)

      Nexus won't start. Its stopping with this error-message :
      jvm 1 | ---- Debugging information ----
      jvm 1 | message : Cannot construct org.codehaus.plexus.util.xml.Xpp3Dom as it does not have a no-args constructor
      jvm 1 | cause-exception : com.thoughtworks.xstream.converters.reflection.ObjectAccessException
      jvm 1 | cause-message : Cannot construct org.codehaus.plexus.util.xml.Xpp3Dom as it does not have a no-args constructor
      jvm 1 | class : org.sonatype.nexus.configuration.model.Configuration
      jvm 1 | required-type : org.codehaus.plexus.util.xml.Xpp3Dom
      jvm 1 | path : /org.sonatype.nexus.configuration.model.Configuration/repositories/org.sonatype.nexus.configuration.model.CRepository/externalConfiguration
      jvm 1 | line number : 40
      jvm 1 | -------------------------------

      ( workaround : switching to jdk 1.6_26 let's me run nexus - without any problems )

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jensritter Jens Ritter
                Last Updated By:
                Rich Seddon
              • Votes:
                1 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: