Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-31811

UI: Settings "Search request timeout" does not look like utilised

    Details

    • Type: Bug
    • Status: New
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 3.38.1
    • Fix Version/s: None
    • Component/s: Search
    • Notability:
      3

      Description

      SYMPTOM:

      On a relatively large Nexus, the administrator would like to stop expensive (elastic) search queries running long time, so that set some integer value in "Search request timeout", but this did not look like making any difference:

      REPRODUCE STEPS:

      1. Prepare Nexus which has many assets.
      2. From UI: settings capability, set the value to 1, like above screen capture
      3. Use some search word which would return many assets (eg: "*")

      EXPECTED RESULT:

      Probably some timeout warning popup, so that Nexus will not keep running expensive elasticsearch queries?

      ACTUAL RESULT:

      Search works normally even it took more than 1 second.
      Probably because org.sonatype.nexus.coreui.SearchComponent#componentSearch has the "seconds" in the 4th argument but does not look like utilised any more?

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            hosako Hajime Osako
            Last Updated By:
            Hajime Osako Hajime Osako
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:

                tigCommentSecurity.panel-title