Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-3048

HTTP 401 error upon attempting to upload artifact to thirdparty repo from command-line

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.4.0
    • Fix Version/s: 1.4.1
    • Component/s: None
    • Labels:
      None

      Description

      Dear All,

      We've encountered this problem before, it was somehow solved, and now came back. We can't update our third party oracle jars as a result, which hinders our development. We could do that using the Nexus UI, which is recommended by Sonatype, but the CLI is far more useful to us as we have hundreds to artifacts we would like to load in batch mode.

      For example, here is the mvn output of deploying a file:

      [tools@dev-tools lib]$ mvn deploy:deploy-file -DgroupId=com.oracle -DartifactId=xmlparserv2 -Dversion=11.1.0.7.0 -Dfile=xmlparserv2.jar -DrepositoryId=thirdparty -Durl=http://dev-tools.further.utah.edu/nexus/content/repositories/thirdparty -Dpackaging=jar
      [INFO] Scanning for projects...
      [INFO]
      [INFO] ------------------------------------------------------------------------
      [INFO] Building Maven Stub Project (No POM) 1
      [INFO] ------------------------------------------------------------------------
      [INFO]
      [INFO] — maven-deploy-plugin:2.4:deploy-file (default-cli) @ standalone-pom —
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 1.235s
      [INFO] Finished at: Fri Nov 27 11:17:10 MST 2009
      [INFO] Final Memory: 7M/309M
      [INFO] ------------------------------------------------------------------------
      [ERROR] Error deploying artifact: Failed to transfer file: http://dev-tools.further.utah.edu/nexus/content/repositories/thirdparty/com/oracle/xmlparserv2/11.1.0.7.0/xmlparserv2-11.1.0.7.0.jar. Return code is: 401
      [ERROR] To see the full stack trace of the error, re-run Maven with the -e switch.
      [ERROR] Re-run Maven using the -X switch to enable full debug logging.
      [ERROR]
      [ERROR] For more information about the error and possible solutions, please try the following article:
      [ERROR] http://
      [tools@dev-tools lib]$

      In $MAVEN_HOME/conf/settings.xml:

      <server>
      <id>thirdparty</id>
      <username>oren</username>
      <password>****</password>
      </server>

      • The user "oren" has all possible roles in the Nexus UI.
      • Tried with both RELEASE and SNAPSHOT policy on the thirdparty repo, with the same result.
      • Nexus log (in System Files) does not show any authentication failure messages.

      Thank you in advance for your help,
      Oren

        Attachments

          Activity

            People

            Assignee:
            velo Marvin Herman Froeder
            Reporter:
            universityofutah-01 Oren Livne
            Last Updated By:
            Peter Lynch Peter Lynch
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Date of First Response:

                Time Tracking

                Estimated:
                Original Estimate - 2h
                2h
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 2h
                2h

                  tigCommentSecurity.panel-title