Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-29380

NX3: reconcile from blob store task can generate invalid npm version entries in metadata

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.35.0
    • Fix Version/s: 3.37.0
    • Component/s: NPM
    • Labels:
      None
    • Story Points:
      2
    • Sprint:
      NXRM MadMax Sprint 19

      Description

      1. Create npm hosted repository.
      2. Run "npm init" to generate package.json and set version like this "1.0.0+aaa".
      3. Run "npm publish".
      4. Open package metadata in UI. The version there should be 1.0.0.
      5. Create and run task "Repair - Reconcile component database from blob store"
      6. There is version "1.0.0+aaa" added to package metadata.

       

      Expected:

      There should be no versions with build metadata like "1.0.0+aaa"

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              ybulatnikov Eugene Bulatnikov
              Reporter:
              ybulatnikov Eugene Bulatnikov
              Last Updated By:
              Peter Lynch Peter Lynch
              Team:
              NXRM - Mad Max
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response:

                  tigCommentSecurity.panel-title