Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-2867

Fix classloading problems in nexus plugins when using latest classworlds

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Out of scope
    • Affects Version/s: None
    • Fix Version/s: 1.4.0
    • Component/s: None
    • Labels:
      None

      Description

      Upgrading to latest plexus container (1.4.0-SNAPSHOT) requires using classworlds 2.2.
      When using those nexus plugins are not loaded properly (injection does not work).

      Same issue as in NXCM-1218, which was solved by reverting to older version of plexus container that is known as been working with Nexus.

        Attachments

          Activity

            People

            • Assignee:
              alin Alin Dreghiciu
              Reporter:
              alin Alin Dreghiciu
              Last Updated By:
              Jason Dillon
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0h
                0h
                Logged:
                Time Spent - 4h
                4h