Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-28027

nexus-m2settings-maven-plugin:1.6.8 isn't compatible with Java 16

    Details

    • Type: Bug
    • Status: New
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Maven
    • Labels:

      Description

      Hi team,

      I found thatĀ org.sonatype.plugins:nexus-m2settings-maven-plugin:1.6.8 isn't compatible with Java 16, now thatĀ JEP 396 is blocking the illegal accesses between modules

      I am not sure if it is specific to this plugin or a more general Maven error.

      mvn org.sonatype.plugins:nexus-m2settings-maven-plugin:1.6.8:download
      [INFO] Scanning for projects...
      [INFO]
      [INFO] ------------------< org.apache.maven:standalone-pom >-------------------
      [INFO] Building Maven Stub Project (No POM) 1
      [INFO] --------------------------------[ pom ]---------------------------------
      [INFO]
      [INFO] --- nexus-m2settings-maven-plugin:1.6.8:download (default-cli) @ standalone-pom ---
      Nexus URL: https://somewhere.acme.com
      Username [arnaud]: itsme
      Password: ***************************************
      [INFO] Connecting to: https://somewhere.acme.com (as itsme)
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time:  23.367 s
      [INFO] Finished at: 2021-06-18T09:20:33+02:00
      [INFO] ------------------------------------------------------------------------
      [ERROR] Failed to execute goal org.sonatype.plugins:nexus-m2settings-maven-plugin:1.6.8:download (default-cli) on project standalone-pom: Execution default-cli of goal org.sonatype.plugins:nexus-m2settings-maven-plugin:1.6.8:download failed: An API incompatibility was encountered while executing org.sonatype.plugins:nexus-m2settings-maven-plugin:1.6.8:download: java.lang.ExceptionInInitializerError: null
      [ERROR] -----------------------------------------------------
      [ERROR] realm =    plugin>org.sonatype.plugins:nexus-m2settings-maven-plugin:1.6.8
      [ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
      [ERROR] urls[0] = file:/Users/arnaud/.m2/repository/org/sonatype/plugins/nexus-m2settings-maven-plugin/1.6.8/nexus-m2settings-maven-plugin-1.6.8.jar
      [ERROR] urls[1] = file:/Users/arnaud/.m2/repository/org/sonatype/gossip/gossip-bootstrap/1.8/gossip-bootstrap-1.8.jar
      [ERROR] urls[2] = file:/Users/arnaud/.m2/repository/org/sonatype/sisu/sisu-inject-bean/2.3.0/sisu-inject-bean-2.3.0.jar
      [ERROR] urls[3] = file:/Users/arnaud/.m2/repository/org/sonatype/sisu/sisu-guice/3.1.0/sisu-guice-3.1.0-no_aop.jar
      [ERROR] urls[4] = file:/Users/arnaud/.m2/repository/org/sonatype/sisu/sisu-guava/0.9.9/sisu-guava-0.9.9.jar
      [ERROR] urls[5] = file:/Users/arnaud/.m2/repository/org/sonatype/aether/aether-util/1.13.1/aether-util-1.13.1.jar
      [ERROR] urls[6] = file:/Users/arnaud/.m2/repository/org/codehaus/plexus/plexus-utils/3.0.8/plexus-utils-3.0.8.jar
      [ERROR] urls[7] = file:/Users/arnaud/.m2/repository/org/codehaus/plexus/plexus-component-annotations/1.5.5/plexus-component-annotations-1.5.5.jar
      [ERROR] urls[8] = file:/Users/arnaud/.m2/repository/org/sonatype/plexus/plexus-sec-dispatcher/1.4/plexus-sec-dispatcher-1.4.jar
      [ERROR] urls[9] = file:/Users/arnaud/.m2/repository/org/sonatype/plexus/plexus-cipher/1.7/plexus-cipher-1.7.jar
      [ERROR] urls[10] = file:/Users/arnaud/.m2/repository/com/google/guava/guava/14.0.1/guava-14.0.1.jar
      [ERROR] urls[11] = file:/Users/arnaud/.m2/repository/jline/jline/2.9/jline-2.9.jar
      [ERROR] urls[12] = file:/Users/arnaud/.m2/repository/org/codehaus/plexus/plexus-interpolation/1.15/plexus-interpolation-1.15.jar
      [ERROR] urls[13] = file:/Users/arnaud/.m2/repository/org/sonatype/nexus/nexus-client-core/2.14.3-02/nexus-client-core-2.14.3-02.jar
      [ERROR] urls[14] = file:/Users/arnaud/.m2/repository/org/sonatype/nexus/plugins/nexus-restlet1x-model/2.14.3-02/nexus-restlet1x-model-2.14.3-02.jar
      [ERROR] urls[15] = file:/Users/arnaud/.m2/repository/com/google/code/findbugs/jsr305/2.0.1/jsr305-2.0.1.jar
      [ERROR] urls[16] = file:/Users/arnaud/.m2/repository/com/intellij/annotations/9.0.4/annotations-9.0.4.jar
      [ERROR] urls[17] = file:/Users/arnaud/.m2/repository/commons-io/commons-io/2.4/commons-io-2.4.jar
      [ERROR] urls[18] = file:/Users/arnaud/.m2/repository/com/thoughtworks/xstream/xstream/1.4.7/xstream-1.4.7.jar
      [ERROR] urls[19] = file:/Users/arnaud/.m2/repository/xmlpull/xmlpull/1.1.3.1/xmlpull-1.1.3.1.jar
      [ERROR] urls[20] = file:/Users/arnaud/.m2/repository/xpp3/xpp3_min/1.1.4c/xpp3_min-1.1.4c.jar
      [ERROR] urls[21] = file:/Users/arnaud/.m2/repository/joda-time/joda-time/2.2/joda-time-2.2.jar
      [ERROR] urls[22] = file:/Users/arnaud/.m2/repository/commons-lang/commons-lang/2.6/commons-lang-2.6.jar
      [ERROR] urls[23] = file:/Users/arnaud/.m2/repository/org/sonatype/sisu/siesta/siesta-client/1.7/siesta-client-1.7.jar
      [ERROR] urls[24] = file:/Users/arnaud/.m2/repository/org/sonatype/sisu/siesta/siesta-common/1.7/siesta-common-1.7.jar
      [ERROR] urls[25] = file:/Users/arnaud/.m2/repository/javax/ws/rs/jsr311-api/1.1.1/jsr311-api-1.1.1.jar
      [ERROR] urls[26] = file:/Users/arnaud/.m2/repository/com/sun/jersey/jersey-core/1.17.1/jersey-core-1.17.1.jar
      [ERROR] urls[27] = file:/Users/arnaud/.m2/repository/javax/validation/validation-api/1.1.0.Final/validation-api-1.1.0.Final.jar
      [ERROR] urls[28] = file:/Users/arnaud/.m2/repository/com/sun/jersey/jersey-client/1.17.1/jersey-client-1.17.1.jar
      [ERROR] urls[29] = file:/Users/arnaud/.m2/repository/com/sun/jersey/contribs/jersey-apache-client4/1.17.1/jersey-apache-client4-1.17.1.jar
      [ERROR] urls[30] = file:/Users/arnaud/.m2/repository/org/sonatype/sisu/siesta/siesta-jackson/1.7/siesta-jackson-1.7.jar
      [ERROR] urls[31] = file:/Users/arnaud/.m2/repository/com/fasterxml/jackson/core/jackson-annotations/2.3.1/jackson-annotations-2.3.1.jar
      [ERROR] urls[32] = file:/Users/arnaud/.m2/repository/com/fasterxml/jackson/core/jackson-core/2.3.1/jackson-core-2.3.1.jar
      [ERROR] urls[33] = file:/Users/arnaud/.m2/repository/com/fasterxml/jackson/core/jackson-databind/2.3.1/jackson-databind-2.3.1.jar
      [ERROR] urls[34] = file:/Users/arnaud/.m2/repository/com/fasterxml/jackson/jaxrs/jackson-jaxrs-json-provider/2.3.1/jackson-jaxrs-json-provider-2.3.1.jar
      [ERROR] urls[35] = file:/Users/arnaud/.m2/repository/com/fasterxml/jackson/jaxrs/jackson-jaxrs-base/2.3.1/jackson-jaxrs-base-2.3.1.jar
      [ERROR] urls[36] = file:/Users/arnaud/.m2/repository/com/fasterxml/jackson/module/jackson-module-jaxb-annotations/2.3.1/jackson-module-jaxb-annotations-2.3.1.jar
      [ERROR] urls[37] = file:/Users/arnaud/.m2/repository/org/apache/httpcomponents/httpclient/4.3.5/httpclient-4.3.5.jar
      [ERROR] urls[38] = file:/Users/arnaud/.m2/repository/commons-codec/commons-codec/1.6/commons-codec-1.6.jar
      [ERROR] urls[39] = file:/Users/arnaud/.m2/repository/org/apache/httpcomponents/httpcore/4.3.2/httpcore-4.3.2.jar
      [ERROR] urls[40] = file:/Users/arnaud/.m2/repository/org/slf4j/jcl-over-slf4j/1.7.7/jcl-over-slf4j-1.7.7.jar
      [ERROR] urls[41] = file:/Users/arnaud/.m2/repository/commons-beanutils/commons-beanutils-core/1.8.3/commons-beanutils-core-1.8.3.jar
      [ERROR] urls[42] = file:/Users/arnaud/.m2/repository/org/slf4j/slf4j-simple/1.7.7/slf4j-simple-1.7.7.jar
      [ERROR] Number of foreign imports: 1
      [ERROR] import: Entry[import  from realm ClassRealm[maven.api, parent: null]]
      [ERROR]
      [ERROR] -----------------------------------------------------
      [ERROR] : Unable to make field private final java.util.Comparator java.util.TreeMap.comparator accessible: module java.base does not "opens java.util" to unnamed module @6f952d6c
      [ERROR] -> [Help 1]
      [ERROR]
      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
      [ERROR] Re-run Maven using the -X switch to enable full debug logging.
      [ERROR]
      [ERROR] For more information about the errors and possible solutions, please read the following articles:
      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginContainerException

      I am not sure if it is the right place to report such bug on the plugin but I didn't find a better place.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            aheritier Arnaud Heritier
            Last Updated By:
            Joe Tom Joe Tom
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                tigCommentSecurity.panel-title