The interface PeriodicJobService implementation org.sonatype.nexus.scheduling.internal.PeriodicJobServiceImpl uses the name "periodic" to name its threads. The issue is this service is seemingly intended to be a generic service that any code can consume. ( currently rhc, some search and browse features and blob store metrics file updater threads use it ), and as such the thread names it spawns look like periodic-X-thread-XX
Thread names should be named contextually to aid debugging and support efforts.
Adjust the PeriodicJobServiceImpl so that a consumer of it is forced to specify a custom name, and fix the existing usages of that interface so that the names are contextual ( example names like blobstore-metrics-updater , rhc-repo-check, etc. )