Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-24356

blobs not deleted after repository re-create on other blob store.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.23.0
    • Fix Version/s: None
    • Component/s: Blobstore
    • Labels:

      Description

      My default blob store was running out of disk space. I deleted the yum hosted repo and re-created it, using the same name, on another blob store (s3).

      However I see that only a very small portion of data has been removed from the default blob store. I'm pretty sure that no other repositories are using the default blob store.

      I already ran the compact blob store (daily in fact) and already tried a full re-scan for deleted blobs. (rebuildDeletedBlobIndex=true) and the blob count for the default blob store is still ~260k. 

       

      bash-5.0# cat 563d116f-8857-4273-9869-91b9a180ab96.properties
      #2020-06-10 20:59:48,652+0000
      #Wed Jun 10 20:59:48 GMT 2020
      @BlobStore.created-by=main-rw
      size=15230004
      @Bucket.repo-name=main
      creationTime=1591822788652
      @BlobStore.created-by-ip=10.244.23.0
      @BlobStore.content-type=application/x-rpm
      @BlobStore.blob-name=snapshots-release/x86_64/Packages/2020/06/10/X-debuginfo-0.0.0-21292.x86_64.rpm
      sha1=fc003d6fb56921090dcaf7e6f694866c0f315b33

       

      However, this repo doesn't exist any more in this (default) blob store.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            jansmets Jan Smets
            Last Updated By:
            Joe Tom Joe Tom
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Date of First Response:

                tigCommentSecurity.panel-title