Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-24019

Use newer AWS SDK to support IRSA

    Details

      Description

      AWS EKS supports a built-in system for assigning IAM roles to pods, which requires the application running in said pod to be able to use sts:AssumeRoleWithWebIdentity method to assume the role specified in the service account annotation. This is useful for seamless nexus compatibility with AWS EKS.

      https://docs.aws.amazon.com/eks/latest/userguide/iam-roles-for-service-accounts-minimum-sdk.html

      AWS SDK supports it out of the box starting with version 1.11.704

      Is it possible to update AWS SDK to this version in the next release?

       

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              mjohnson Matt Johnson
              Reporter:
              Sablin Artem
              Last Updated By:
              Joe Tom Joe Tom
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response:

                  tigCommentSecurity.panel-title