Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-23749

npm install failed: code EINTEGRITY due to two npm package with the same version for hana-client

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 3.22.1
    • Fix Version/s: None
    • Component/s: NPM
    • Labels:

      Description

      when to specify @sap/hana-client version: 2.4.196 in my project, it will caused npm install failed: code EINTEGRITY.

      Here I suspect it is due to two npm package with the same version for hana-client: one is for milestone and the other is for release.

      Refer to attached screenshots.

        Attachments

        1. debug log for npm install.png
          debug log for npm install.png
          166 kB
        2. screenshot-1.png
          screenshot-1.png
          128 kB
        3. screenshot-2.png
          screenshot-2.png
          60 kB
        4. screenshot-3.png
          screenshot-3.png
          16 kB
        5. screenshot-4.png
          screenshot-4.png
          15 kB

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            zhongpe Peyton Zhong
            Last Updated By:
            Joe Tom Joe Tom
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Date of First Response:

                tigCommentSecurity.panel-title