Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-23614

"data-requires-python" attribute does not work with group repository

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Automatically Closed
    • Affects Version/s: 3.22.1
    • Fix Version/s: None
    • Component/s: PyPI
    • Labels:

      Description

      data-requires-python is not present using group repository pypi-all.

        Found link http://nexus-dt1.cloud.com/repository/pypi-all/packages/jinja2/3.0.0a1/Jinja2-3.0.0a1.tar.gz#sha256=c922560ac46888d47384de1dbdc3daaa2ea993af4b26a436dec31fa2c19ec668 (from http://nexus-dt1.cloud.core.pw/repository/pypi-all/simple/jinja2/), version: 3.0.0a1

      However, when I point pip to member of pypi-all - pypi, I get correct response:

        Skipping link: none of the wheel's tags match: py3-none-any: http://nexus-dt1.cloud.com/repository/pypi/packages/jinja2/3.0.0a1/Jinja2-3.0.0a1-py3-none-any.whl#sha256=c10142f819c2d22bdcd17548c46fa9b77cf4fda45097854c689666bf425e7484 (from http://nexus-dt1.cloud.core.pw/repository/pypi/simple/jinja2/) (requires-python:>=3.6)

      What information should I provide to fix this bug?

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              ftarasenko Fedor Tarasenko
              Last Updated By:
              Sonatype Support Sonatype Support
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response:

                  tigCommentSecurity.panel-title