Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-20264

pip install from pypi.org and Nexus Repository can get different results

    Details

    • Type: Bug
    • Status: Open
    • Priority: Medium
    • Resolution: Unresolved
    • Affects Version/s: 3.16.2
    • Fix Version/s: None
    • Component/s: PyPI
    • Labels:
      None
    • Environment:
      tested with python2, python3.5, and nexus 3.16.2

      Description

      Ran into an issue regarding pip installs/downloads from the proxy repo vs directly from pypi.org. Expected behavior is that doing a pip install from the proxy repo should result in the same behavior as a pip install from pypi actual.

      `pip2 download -i https://pypi.org/simple matplotlib` results in matplotlib version 1.5.1 which is the latest version that is compatible with python2 and is installed successfully

      `pip2 download -i http://localhost:8072/repository/pypi/simple matplotlib` attempts to get version 3.1.0:

      ```Looking in indexes: http://localhost:8072/repository/pypi/simple
      Collecting matplotlib
      Downloading http://localhost:8072/repository/pypi/packages/51/fe/84ab101f8ab543d89b6a128326f62adcdafd2781ab8362a737e6ce78eea7/matplotlib-3.1.0.tar.gz (37.2MB)
      100% |████████████████████████████████| 37.2MB 56.7MB/s
      Saved ./matplotlib-3.1.0.tar.gz
      Complete output from command python setup.py egg_info:

      Beginning with Matplotlib 3.1, Python 3.6 or above is required.

      This may be due to an out of date pip.

      Make sure you have pip >= 9.0.1.

      ----------------------------------------
      Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-download-gFLKNu/matplotlib/
      You are using pip version 10.0.1, however version 19.1.1 is available.
      You should consider upgrading via the 'pip install --upgrade pip' command.```
      A similar thing happens with a pip3 install where 3.0.3 is the latest compatible version with python3.5 and doing it from the proxy repo results in it attempting to download 3.1.0 again with the same error:
      ```(matplotlib-python3) ajurgenson@ArtieSonaDell:~/py-envs$ pip3 download -i http://localhost:8072/repository/pypi/simple m
      atplotlib
      Looking in indexes: http://localhost:8072/repository/pypi/simple
      Collecting matplotlib
      File was already downloaded /home/ajurgenson/py-envs/matplotlib-3.1.0.tar.gz
      Complete output from command python setup.py egg_info:

      Beginning with Matplotlib 3.1, Python 3.6 or above is required.

      This may be due to an out of date pip.

      Make sure you have pip >= 9.0.1.

      ----------------------------------------
      Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-download-fhsxf603/matplotlib/```

       

      This happens with pip install -i <repo> as well, the commands are analogous 

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            ajurgenson Artemie Jurgenson
            Last Updated By:
            Joe Tom Joe Tom
            Votes:
            4 Vote for this issue
            Watchers:
            6 Start watching this issue

              Dates

              Created:
              Updated:
              Date of First Response:

                tigCommentSecurity.panel-title