Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-19998

Blobstore update warning untrue

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: New
    • Priority: Trivial
    • Resolution: Unresolved
    • Affects Version/s: 3.17.0
    • Fix Version/s: None
    • Component/s: Blobstore, UI
    • Labels:

      Description

      I noticed that if you have limited priviliges like nx-blobstore-read there is a message in the UI next to discard "Update is not supported for blob stores".
      I believe back when we had simple "File" only this was true, but now update allows soft quota changes, promotion to group, group adjustments, S3 configuration and even changing of path. The message seems way too generic even untrue.

      Borderline improvement but I went with bug because of the untruth.

      Suggestion is to change this message to match repositories "You do not have permission to update blob stores".
      I would have just changed this myself but I'm not sure if there's a case where this message as written is actually appropriate.
      If folks feel there isn't, feel free to denote here and I can look into submitting a PR.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            jtom Joe Tom
            Last Updated By:
            Joe Tom Joe Tom
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                tigCommentSecurity.panel-title