Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-19989

Special characters are not URL encoded in the "path" link in WebUI

    Details

    • Type: Bug
    • Status: Open
    • Priority: Medium
    • Resolution: Unresolved
    • Affects Version/s: 3.15.2, 3.17.0
    • Fix Version/s: None
    • Component/s: UI, Upload UI
    • Labels:

      Description

      Hello,

      I noticed that the special characters are not encoded in the link behind the "Path" in the WebUI, making it impossible to download a component with spaces or other non standard characters.

      For example I can upload this component: special#chars.txt

      It will display correctly in the Browse repo .

      However if I click on the link in the "Path" section, it will report 404 error.

      The link is this one:

      https://<nexus host>/nexus/repository/repo/special#chars.txt

      instead of this one:

      https://<nexus host>/nexus/repository/repo/special%23chars.txt

      Is this an incorrect usage on our side or a UI defect ?
      Thanks
      Cedric

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              Quilliot Cedric
              Last Updated By:
              Joe Tom Joe Tom
              Votes:
              2 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Date of First Response:

                  tigCommentSecurity.panel-title