Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-198

Creating a user with no Roles selected does not produce error in UI or Nexus.log

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0-beta
    • Fix Version/s: 1.0-beta
    • Component/s: None
    • Labels:
      None

      Description

      Users => Select New => Enter in all required information, however do not assign any Roles from the Available Role to the Selected Roles column => Select Save => No errors appear in the UI or the nexus.log, however the user is not added to the app. Looked in the wrapper.log and the following is logged:
      INFO | jvm 1 | 2008/07/08 10:15:40 | INFO: The userId (User1) cannot have 0 roles!
      INFO | jvm 1 | 2008/07/08 10:15:40 | Jul 8, 2008 10:15:40 AM com.noelios.restlet.LogFilter afterHandle

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              koconnor Kristine O'Connor
              Reporter:
              koconnor Kristine O'Connor
              Last Updated By:
              Peter Lynch Peter Lynch
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 6h
                  6h

                    tigCommentSecurity.panel-title