Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-19602

System Nodes View in UI incorrectly shows wrong state of read only mode button

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: New
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 3.16.0, 3.21.1
    • Fix Version/s: None
    • Component/s: UI
    • Labels:

      Description

      The Enable/Disable read-only mode button on the System Nodes page always shows Enable when the page is refreshed.

      Steps to reproduce:

      • Visit the Nodes Page
      • Click Enable read-only mode and confirm in the pop-up
      • Confirm button shows Disable read-only mode
      • Refresh page
      • Button now shows Enable read-only mode again
      • Clicking again will result in an error in the logs because it is already in read only mode

      Expected:
      Button correctly reflects backend state between refreshes.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              mjohnson Matt Johnson
              Last Updated By:
              Joe Tom Joe Tom
              Team:
              NXRM - Tron
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:

                  tigCommentSecurity.panel-title