Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-18235

Require Java 8 for NXRM 2

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.14.10
    • Fix Version/s: 2.14.11
    • Component/s: Bootstrap
    • Labels:
      None
    • Release Note:
      Yes

      Description

      Versions of Nexus Repository Manager 2.14.0 to 2.14.10 were recommended to use Java 8. Running with Java 7 was still possible, although Sonatype was not testing builds with it.

      On August 2, 2018 public announcements were made strongly recommending avoiding older java versions such as Java 7.

      Due to security vulnerabilities found in some repository manager dependencies, we are now forced to require Java 8 when running repository manager 2.x ( 2.14.11 and newer ).

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            plynch Peter Lynch
            Last Updated By:
            Peter Lynch
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Date of First Response:

                tigCommentSecurity.panel-title