Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-13326

Layer Id search field doesn't work

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.4.0, 3.26.1
    • Fix Version/s: None
    • Component/s: Docker, Search
    • Labels:

      Description

      While testing REST search, I was trying to find a value from the Search UI for the docker "Layer Id" field. After review and discussion with the team, I am not convinced that any value will ever be able to be found.
      Search only returns component values and the only asset that seems to be associated with a component value seems to be the manifest which as far as I can tell does not have a layer.

      I checked the DB and the values pulled from the docker CLI as well as perused some on the internet but I have been unable to find any results. As such that portion of the REST search has been untested (if there is a valid layer). I am however marking minor because this field is working properly (not returning values incorrectly) as far as I can tell. Just our setup does not support searching in this way.
      I did not check older NXRM3 versions at this time but am highly skeptical this is new.

      Acceptance criteria:

      • The Layer Id field is removed from the UI

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              jtom Joe Tom
              Last Updated By:
              Peter Lynch Peter Lynch
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Date of First Response:

                  tigCommentSecurity.panel-title