Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-13127

Anonymous access to repositories does not work when "Require user tokens for repository authentication" is set

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.3.1
    • Fix Version/s: 3.4.0
    • Component/s: User Token
    • Labels:
    • Story Points:
      2
    • Release Note:
      Yes
    • Sprint:
      Core Team - Sprint 95

      Description

      Configure user token access in the server, and enable "Require user tokens for repository authentication".  Then run a Maven build against the server against a repository that allows anonymous read access.

       

      The build will fail, a 401 response is sent.

       

      The "Require user tokens for repository authentication" feature should not block anonymous requests.  It should only block requests that are sent with credentials that are not user tokens.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              ecobb Eric Cobb
              Reporter:
              rseddon Rich Seddon
              Last Updated By:
              Peter Lynch
              Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response:

                  tigCommentSecurity.panel-title