Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-13098

log and prevent startup when the started Nexus version is using a data directory from a newer Nexus version

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0, 3.3.1
    • Fix Version/s: 3.4.0
    • Component/s: Bootstrap
    • Labels:
    • Story Points:
      1
    • Sprint:
      Platform Team - Sprint 96, Platform Team - Sprint 97

      Description

      Nexus 2 detected and failed startup in most cases where configuration file compatibility versions were conflicting.

      Some Nexus 3 users accidentally or intentionally startup old versions of Nexus 3 against newer upgraded versions of Nexus 3 data directories. This may lead to potential problems and is certainly a state which is considered "unknown". This complicates trying to solve any other reported problem with a running instance.

      Expected

      • Nexus 3 should detect startup against incompatible data directories/files (ie. those with later schema versions compared to the installation attempting to run), fail, and log a SEVERE message indicating the problem into the nexus.log

        Attachments

          Activity

            People

            Assignee:
            nblair Nicholas Blair
            Reporter:
            plynch Peter Lynch
            Last Updated By:
            Peter Lynch
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Date of First Response:

                tigCommentSecurity.panel-title