Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-12685

upgrade httpclient dependency to 4.5.4 or greater

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.2.1
    • Fix Version/s: 3.11.0
    • Component/s: Transport
    • Labels:

      Description

      nexus 3.2.1 uses httpclient 4.5.2

      There are lots of issues fixed in 4.5.3. Some SSL related issues may be affecting our users.
      There are even more (verified) issues in 4.5.3 (see comments below). Waiting for 4.5.4 now.

      https://github.com/apache/httpclient/blob/4.5.x/RELEASE_NOTES.txt

      Notable Issues:

      https://issues.apache.org/jira/browse/HTTPCLIENT-1744
      https://issues.apache.org/jira/browse/HTTPCLIENT-1802
      https://issues.apache.org/jira/browse/HTTPCLIENT-1792
      https://issues.apache.org/jira/browse/HTTPCLIENT-1726

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              jbryan Jeremy Bryan
              Reporter:
              plynch Peter Lynch
              Last Updated By:
              Peter Lynch Peter Lynch
              Team:
              Nexus - Core
              Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response:

                  tigCommentSecurity.panel-title