Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-12540

Unable to Start Nexus-public

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 3.2.1, 3.3.0
    • Fix Version/s: 3.4.0
    • Component/s: Build
    • Labels:
      None
    • Story Points:
      2

      Description

      I am following directions at https://www.github.com/sonatype/nexus-public. I am running on OS X with:

      java version "1.8.0_111"
      Java(TM) SE Runtime Environment (build 1.8.0_111-b14)
      Java HotSpot(TM) 64-Bit Server VM (build 25.111-b14, mixed mode)
      
      Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=512m; support was removed in 8.0
      Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T09:41:47-07:00)
      Maven home: /usr/local/Cellar/maven/3.3.9/libexec
      Java version: 1.8.0_111, vendor: Oracle Corporation
      Java home: /Library/Java/JavaVirtualMachines/jdk1.8.0_111.jdk/Contents/Home/jre
      Default locale: en_US, platform encoding: UTF-8
      OS name: "mac os x", version: "10.12.3", arch: "x86_64", family: "mac"
      

      Nexus is unable to start with the following stacktrace:

      2017-03-11 14:54:36,737-0700 INFO  [FelixStartLevel] *SYSTEM org.sonatype.nexus.internal.orient.DatabaseServerImpl - Activated
      2017-03-11 14:54:36,743-0700 INFO  [FelixStartLevel] *SYSTEM org.sonatype.nexus.extender.NexusLifecycleManager - Start UPGRADE
      2017-03-11 14:54:37,841-0700 WARN  [FelixStartLevel] *SYSTEM org.sonatype.nexus.upgrade.plan.DependencyResolver - ComponentDatabaseUpgrade_1_2{upgrades=@org.sonatype.nexus.common.upgrade.Upgrades(model=component, from=1.1, to=1.2), dependsOn=[]} requires UpgradeDependency{model='component', version='1.1'}
      2017-03-11 14:54:37,928-0700 ERROR [FelixStartLevel] *SYSTEM org.sonatype.nexus.upgrade.internal.UpgradeServiceImpl - Failed transition: NEW -> STARTED
      org.sonatype.nexus.upgrade.plan.DependencyResolver$UnresolvedDependencyException: 1 unresolved dependency: ComponentDatabaseUpgrade_1_2{upgrades=@org.sonatype.nexus.common.upgrade.Upgrades(model=component, from=1.1, to=1.2), dependsOn=[]} requires UpgradeDependency{model='component', version='1.1'}
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) [na:1.8.0_111]
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) [na:1.8.0_111]
      	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) [na:1.8.0_111]
      	at java.lang.reflect.Constructor.newInstance(Constructor.java:423) [na:1.8.0_111]
      	at org.codehaus.groovy.reflection.CachedConstructor.invoke(CachedConstructor.java:83) [na:na]
      	at org.codehaus.groovy.runtime.callsite.ConstructorSite$ConstructorSiteNoUnwrapNoCoerce.callConstructor(ConstructorSite.java:105) [na:na]
      	at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCallConstructor(CallSiteArray.java:60) [na:na]
      	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callConstructor(AbstractCallSite.java:235) [na:na]
      	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callConstructor(AbstractCallSite.java:247) [na:na]
      	at org.sonatype.nexus.upgrade.plan.DependencyResolver.resolve(DependencyResolver.groovy:149) [na:na]
      	at org.sonatype.nexus.upgrade.internal.UpgradeManager.order(UpgradeManager.java:113) [na:na]
      	at org.sonatype.nexus.upgrade.internal.UpgradeManager.plan(UpgradeManager.java:81) [na:na]
      	at org.sonatype.nexus.upgrade.internal.UpgradeServiceImpl.doStart(UpgradeServiceImpl.java:82) [na:na]
      	at org.sonatype.nexus.common.stateguard.StateGuardLifecycleSupport.start(StateGuardLifecycleSupport.java:67) [org.sonatype.nexus.common:3.3.0.SNAPSHOT]
      	at org.sonatype.nexus.common.stateguard.MethodInvocationAction.run(MethodInvocationAction.java:39) [org.sonatype.nexus.common:3.3.0.SNAPSHOT]
      	at org.sonatype.nexus.common.stateguard.StateGuard$TransitionImpl.run(StateGuard.java:191) [org.sonatype.nexus.common:3.3.0.SNAPSHOT]
      	at org.sonatype.nexus.common.stateguard.TransitionsInterceptor.invoke(TransitionsInterceptor.java:56) [org.sonatype.nexus.common:3.3.0.SNAPSHOT]
      	at org.sonatype.nexus.extender.NexusLifecycleManager.startComponent(NexusLifecycleManager.java:154) [org.sonatype.nexus.extender:3.3.0.SNAPSHOT]
      	at org.sonatype.nexus.extender.NexusLifecycleManager.to(NexusLifecycleManager.java:94) [org.sonatype.nexus.extender:3.3.0.SNAPSHOT]
      	at org.sonatype.nexus.extender.NexusContextListener.frameworkEvent(NexusContextListener.java:186) [org.sonatype.nexus.extender:3.3.0.SNAPSHOT]
      	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1429) [org.apache.felix.framework-5.6.1.jar:na]
      	at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) [org.apache.felix.framework-5.6.1.jar:na]
      	at java.lang.Thread.run(Thread.java:745) [na:1.8.0_111]
      2017-03-11 14:54:37,939-0700 ERROR [FelixStartLevel] *SYSTEM org.sonatype.nexus.extender.NexusContextListener - Failed to start nexus
      org.sonatype.nexus.upgrade.plan.DependencyResolver$UnresolvedDependencyException: 1 unresolved dependency: ComponentDatabaseUpgrade_1_2{upgrades=@org.sonatype.nexus.common.upgrade.Upgrades(model=component, from=1.1, to=1.2), dependsOn=[]} requires UpgradeDependency{model='component', version='1.1'}
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) [na:1.8.0_111]
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) [na:1.8.0_111]
      	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) [na:1.8.0_111]
      	at java.lang.reflect.Constructor.newInstance(Constructor.java:423) [na:1.8.0_111]
      	at org.codehaus.groovy.reflection.CachedConstructor.invoke(CachedConstructor.java:83) [na:na]
      	at org.codehaus.groovy.runtime.callsite.ConstructorSite$ConstructorSiteNoUnwrapNoCoerce.callConstructor(ConstructorSite.java:105) [na:na]
      	at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCallConstructor(CallSiteArray.java:60) [na:na]
      	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callConstructor(AbstractCallSite.java:235) [na:na]
      	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callConstructor(AbstractCallSite.java:247) [na:na]
      	at org.sonatype.nexus.upgrade.plan.DependencyResolver.resolve(DependencyResolver.groovy:149) [na:na]
      	at org.sonatype.nexus.upgrade.internal.UpgradeManager.order(UpgradeManager.java:113) [na:na]
      	at org.sonatype.nexus.upgrade.internal.UpgradeManager.plan(UpgradeManager.java:81) [na:na]
      	at org.sonatype.nexus.upgrade.internal.UpgradeServiceImpl.doStart(UpgradeServiceImpl.java:82) [na:na]
      	at org.sonatype.nexus.common.stateguard.StateGuardLifecycleSupport.start(StateGuardLifecycleSupport.java:67) [na:na]
      	at org.sonatype.nexus.common.stateguard.MethodInvocationAction.run(MethodInvocationAction.java:39) [na:na]
      	at org.sonatype.nexus.common.stateguard.StateGuard$TransitionImpl.run(StateGuard.java:191) [na:na]
      	at org.sonatype.nexus.common.stateguard.TransitionsInterceptor.invoke(TransitionsInterceptor.java:56) [na:na]
      	at org.sonatype.nexus.extender.NexusLifecycleManager.startComponent(NexusLifecycleManager.java:154) [na:na]
      	at org.sonatype.nexus.extender.NexusLifecycleManager.to(NexusLifecycleManager.java:94) [na:na]
      	at org.sonatype.nexus.extender.NexusContextListener.frameworkEvent(NexusContextListener.java:186) [na:na]
      	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1429) [org.apache.felix.framework-5.6.1.jar:na]
      	at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) [org.apache.felix.framework-5.6.1.jar:na]
      	at java.lang.Thread.run(Thread.java:745) [na:1.8.0_111]
      ERROR: Framework listener delivery error.
      org.sonatype.nexus.upgrade.plan.DependencyResolver$UnresolvedDependencyException: 1 unresolved dependency: ComponentDatabaseUpgrade_1_2{upgrades=@org.sonatype.nexus.common.upgrade.Upgrades(model=component, from=1.1, to=1.2), dependsOn=[]} requires UpgradeDependency{model='component', version='1.1'}
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
      	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
      	at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
      	at org.codehaus.groovy.reflection.CachedConstructor.invoke(CachedConstructor.java:83)
      	at org.codehaus.groovy.runtime.callsite.ConstructorSite$ConstructorSiteNoUnwrapNoCoerce.callConstructor(ConstructorSite.java:105)
      	at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCallConstructor(CallSiteArray.java:60)
      	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callConstructor(AbstractCallSite.java:235)
      	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callConstructor(AbstractCallSite.java:247)
      	at org.sonatype.nexus.upgrade.plan.DependencyResolver.resolve(DependencyResolver.groovy:149)
      	at org.sonatype.nexus.upgrade.internal.UpgradeManager.order(UpgradeManager.java:113)
      	at org.sonatype.nexus.upgrade.internal.UpgradeManager.plan(UpgradeManager.java:81)
      	at org.sonatype.nexus.upgrade.internal.UpgradeServiceImpl.doStart(UpgradeServiceImpl.java:82)
      	at org.sonatype.nexus.common.stateguard.StateGuardLifecycleSupport.start(StateGuardLifecycleSupport.java:67)
      	at org.sonatype.nexus.common.stateguard.MethodInvocationAction.run(MethodInvocationAction.java:39)
      	at org.sonatype.nexus.common.stateguard.StateGuard$TransitionImpl.run(StateGuard.java:191)
      	at org.sonatype.nexus.common.stateguard.TransitionsInterceptor.invoke(TransitionsInterceptor.java:56)
      	at org.sonatype.nexus.extender.NexusLifecycleManager.startComponent(NexusLifecycleManager.java:154)
      	at org.sonatype.nexus.extender.NexusLifecycleManager.to(NexusLifecycleManager.java:94)
      	at org.sonatype.nexus.extender.NexusContextListener.frameworkEvent(NexusContextListener.java:186)
      	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1429)
      	at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
      	at java.lang.Thread.run(Thread.java:745)
      

      Has anyone encountered this? Is there a way through?

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              r351574nc3 Leo Przybylski
              Last Updated By:
              Peter Lynch
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response:

                  tigCommentSecurity.panel-title