Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-11921

explicitly prevent quarantine enabled Nexus 2 repositories from upgrade into Nexus 3

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.14.1, 3.1.0
    • Fix Version/s: 2.14.2, 3.2.0
    • Component/s: Migration
    • Labels:
      None

      Description

      Background

      Nexus 3.2 supports Nexus Firewall. However Nexus 3.2 does not support migration of Nexus 2.14.2 Firewall/quarantine enabled repositories.

      Acceptance

      Therefore, until Nexus 3 supports migrating quarantine enabled nexus 2 repositories, those repositories with audit/quarantine enabled cannot be selected for migration to NX3. A message is shown explaining why (in the same spot that we do for other repos that can't get migrated, like maven1 repos).

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            plynch Peter Lynch
            Last Updated By:
            Peter Lynch
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                tigCommentSecurity.panel-title