Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.0, 3.2.0
    • Fix Version/s: 3.2.1
    • Component/s: Blobstore
    • Labels:
      None
    • Story Points:
      2
    • Sprint:
      Sprint 85, Sprint 86

      Description

      To replicate:

      1. Start Nexus 3, look at the blob store stats
      2. Migrate content from 2x, in a single repository (hard-linking)
      3. 832 changes are brought across
      4. Blob store stats show 2080 blobs (exactly 2.5x 832)
      5. In Nexus 3, delete the repository that was migrated
      6. Blob store stats now show 832 blobs (which is weird)
      7. Run the 'compact blobstore' scheduled task
      8. Blob store stats now show 832 blobs (still weird)
        => They should be zero.

        Issue Links

          Activity

          jtom Joe Tom added a comment - - edited

          I noticed this (or something similar) testing NEXUS-11642. I pushed a single pom to maven-releases and then deleted it via delete component in the search UI and then ran the compact task. My count was still at 1. I checked the DB and there were no items in components or assets. I checked the file system (sonatype/nexus3/blobs) and there were no items other than folders. Browse assets also shows nothing (was wondering if there was a low level non-component associated xml lurking or something).
          ADDENDUM: I pushed another single pom and the count is now 3. There is one item in asset DB and one item in component DB and 2 files in the filesystem (other than folders). I wonder if A) blob count counts asset once and component once but delete just removes one or B) blobcount counts number of files but on removal only removes one. Both of these are weird tho because they seem to hint at an indepentantly stored count and not that it's counted each time the page is loaded. Which might be how it is, or maybe I'm confused.

          ecobb Eric Cobb added a comment - - edited

          For the sake of extreme clarity, problem can be shown very clearly on a fresh install:

          • create raw repository
          • add one item to it. blob count is now at "2" (should be one)
          • remove that item. Blob count is now at "1" (should be zero)
          ecobb Eric Cobb added a comment - - edited

          Note for testing:

          After talking with Michael Prescott we determined the intended behavior is for metrics to only update when the blobstore is deleted- that is, the purpose of metrics is to show blobs taking up space on disk. The upshot of all this is that post-fix you will need to run compact blob store to see accurate metrics for deletion.

          jtom Joe Tom added a comment - - edited

          Verified this is good now using raw, maven and docker. Thanks!

          NOTE: We are aware this fix does not fix pre-existing issues. We have queued a (currently private) backlog item to make a task to fix metrics broken by this defect (and any future defects). What was resolved is a forward fix.


            People

            • Assignee:
              jtom Joe Tom
              Reporter:
              mprescott Michael Prescott
              Last Updated By:
              Dulani Wallace
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response:

                Agile