Uploaded image for project: 'Dev - Nexus Repo'
  1. Dev - Nexus Repo
  2. NEXUS-10019

Deletion of asset from single asset component causes failure in UI

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.1.0
    • Component/s: Repository, UI
    • Labels:
      None
    • Story Points:
      0.5
    • Sprint:
      Sprint 69, Sprint 70

      Description

      If you have a component with a single asset (as all npm components do) and navigate through Components -> Repo -> Component -> Asset, and then delete the asset using the provided button, the UI attempts to reload the parent component. Problem here is that components are removed when their last asset is deleted, which leads to an error message being shown in the UI and the view not updating.
      I saw this with NPM but likely it's a problem with any format anytime the last asset is deleted.
      http://screencast.com/t/Lfz7oaFIFgiC

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              jtom Joe Tom
              Reporter:
              krobinson Kelly Robinson
              Last Updated By:
              Peter Lynch
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response:

                  tigCommentSecurity.panel-title