Details

    • Type: Problem Problem
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not A Bug
    • Component/s: None
    • Labels:
      None
    • Global Rank:
      1497

      Description

      i use nexus as maven repository proxy.
      everything go well until recently i cannot download artifacts from nexus.

      on repository status tab of Maven Central Repository, showing:
      "In Service - Remote Automatically Blocked and Unavailable"

      other repos proxy status is ok.

      i emailed nexue supporter, and replied "maybe my'IP is blocked by maven central"

      how to fix it. my public ip is : 203.171.235.241

      thanks advance.

        Activity

        Joel Orlina added a comment -

        The Central Repo recently changed IP addresses. You should always be using the domain name, repo1.maven.org, but maybe your Nexus is configured to use an old IP address that no longer functions. Can you check your Nexus settings?

        feng added a comment -

        Remote Storage Location of Maven Central is "http://repo1.apache.org/maven2"
        i always use the domain name.

        replaced by "http://repo1.maven.org" is Not OKay.

        if view these two urls with browser, i got
        "Browsing for this directory has been disabled.

        View this directory's contents on http://search.maven.org instead.
        "

        Joel Orlina added a comment -

        The browser behavior is expected. Web browsers are prohibited from the root directory and several large subdirectories (org/com/net).

        However, deeper points of the repo can still be browsed, e.g. http://repo1.maven.org/maven2/org/apache

        I've gone to the Central server and its mirrors and verified that your IP address has not been blocked by our firewall.

        feng added a comment -

        er...
        maybe it is my network problem.
        when i wget "http://repo1.maven.org/maven2/org/apache" on my server, i got this(i stop the iptable):
        Connecting to repo1.maven.org|207.223.241.90|:80... failed: Connection timed out

        but wget "http://www.linux.org" is OK.

        any suggetion?

        Joel Orlina added a comment -

        Central actually does not permit most non-browser agents (curl, wget, etc.) But, if you make a request with a web browser, Central will allow that through.

        Joel Orlina added a comment -

        Haven't heard anything lately on this issue, so I'm closing as "Not A Bug."


          People

          • Assignee:
            Joel Orlina
            Reporter:
            feng
            Last Updated By:
            Joel Orlina
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: