zDev - M2E - OSS
  1. zDev - M2E - OSS
  2. MNGECLIPSE-1882

Running maven lifecycle phases from M2Eclipse when there is no user settings..xml file fails

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.10.0
    • Fix Version/s: 0.10.1
    • Component/s: Maven Launcher
    • Labels:
      None
    • Global Rank:
      13621

      Description

      If I have no user supplied settings.xml file in ~/.m2 then running Maven lifecycle phases from "Run/Run As..." (such as "Maven install") fails. The Maven console shows:

      [ERROR] Error executing Maven.
      [ERROR] The specified user settings file does not exist: /Users/rseddon/.m2/settings.xml
      

        Activity

        Mike Youngstrom added a comment -

        This is a regression. I'm experiencing the same problem. Worked with old September dev release. Fails with latest dev release dated 11/17.

        Jim Brownfield added a comment -

        Having the same problem here.

        Jim Brownfield added a comment -

        Followup/workaround:

        Sorry, I should have waited until I tried this before commenting, but adding an empty settings.xml (well, empty from an xml standpoint) seems to work:

        <settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
        http://maven.apache.org/xsd/settings-1.0.0.xsd">
        </settings>

        Clemens Fuchslocher added a comment -

        The problem still exists in 0.9.9.200912160759.

        Clemens Fuchslocher added a comment -

        MNG-4408 added a new check which cause this behaviour.

        Clemens Fuchslocher added a comment -

        The problem is still present in 0.10.0.20100209-0800.

        This issue is a real show stopper for new users.

        Shane StClair added a comment -

        Ran into this problem as well. Using Jim Brownfield's fix above.

        Gordon Mohr added a comment - - edited

        Also ran into this in 0.10.0.20100209-0800. Corrected by copying M2_HOME/conf/settings.xml to ~/.m2/.

        Rich Seddon added a comment -

        verified fixed in 0.10.1/N/201004191608/


          People

          • Assignee:
            Benjamin Bentmann
            Reporter:
            Rich Seddon
            Last Updated By:
            Brian Fox
          • Votes:
            4 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: